Mail volume on a subset of SigstrONE servers has now normalized and all queued mail was delivered successfully. Mail should now be delivered without delay.
Posted Mar 23, 2022 - 19:31 EDT
Identified
Our team identified a problem on Microsoft's end with a number of Office365 IP addresses that are not accepting mail. While this has contributed to the email delays, mail flow should be redirected to Office365 IP addresses that are working until this is resolved. We are continuing to monitor mail flow at this time to ensure mail is being delivered successfully.
Posted Mar 23, 2022 - 14:34 EDT
Investigating
We are currently investigating reports of mail queueing on a subset of SigstrONE servers. As a result, email delays of up to 15 minutes may be experienced on the impacted servers. Our team is continuing to monitor mail flow at this time to ensure mail is being delivered successfully.