Email Experiences - Mac Outlook (v. 16.57 & newer) + Office365

Incident Report for Terminus Status

Resolved

Terminus Engineering has deployed an updated version of the Mac Agent that supports new installations when leveraging Outlook v. 16.57 and newer.

Thank you for your patience on this and if you have any questions or concerns moving forward, please reach out to our Platform Support team via the Terminus Help Center at https://support.terminus.com.
Posted Apr 20, 2022 - 17:06 EDT

Identified

Terminus Email Experience signatures do not currently populate for users in Mac Outlook desktop for Office365 accounts with the Mac Agent fully installed. This only impacts net new installations of the Mac Agent when running Outlook v. 16.57 (or newer). Terminus Engineering is aware of this issue and is working on an update for the Mac Agent to ensure signature templates populate in Outlook (v. 16.57 & newer).

Current workarounds include:
-Leverage other email clients such as Mac Mail or Outlook on the web
-Install Outlook v. 16.56 (or earlier) and reinstall the Mac Agent

If you have any questions or concerns, please reach out to our Platform Support team via the Terminus Help Center at https://support.terminus.com.
Posted Apr 15, 2022 - 16:11 EDT